読者です 読者をやめる 読者になる 読者になる

c4se記:さっちゃんですよ☆

.。oO(さっちゃんですよヾ(〃l _ l)ノ゙☆)

.。oO(此のblogは、主に音樂考察Programmingに分類されますよ。ヾ(〃l _ l)ノ゙♬♪♡

音樂はSoundCloud等バラバラの場所に公開中です。申し訳ないがlinkをたどるなどして探してください。

考察は現在は主に此のblogで公表中です。

programmingは、ひろくみせるものはGitHubで、個人的なものはBitBucketで開発中です。

c4se

Ciscoルーター、コマンドのメモ

Programming

Cisco 1800 ルーター
去年書いたmemo。memoなので説明はしない。

* Initilize a router. *
> en
# erase startup-config
# reload
System configuration has been modified. Save? [yes/no] no
Would you like to enter the initial configuration dialog? [yes/no] no

* Enable configure from telnet. *
> en
# config terminal
(config)# line vty 0
(config-line)# password password
(config-line)# login
Some actions.
# erase startup-config

* Connect 3 networks through static routing. *
> en
# config
(config)# interface vlan 1
(config-if)# ip address 192.168.3.254 255.255.255.0
(config-if)# no shutdown
(config-if)# exit
(config)# interface fastEthernet 0
(config-if)# ip address 192.168.2.253 255.255.255.0
(config-if)# no shutdown
(config-if)# exit
(config)# ip route 192.168.1.0 255.255.255.0 192.168.2.254
(config)# exit
# show interfaces vlan 1
# show interfaces fastEthernat 0

* Remove static routing. *
(config)# no ip route 192.168.1.0 255.255.255.0

* Setting default gateway. *
(config)# ip route 0.0.0.0 192.168.2.254

* Connect networks through RIP. *
(config)# router rip
(config-router)# network 192.168.2.0
(config-router)# network 192.168.3.0
(config-router)# exit
(config)# exit
# show running-config
# show cdp neighbors
# show ip route
# show ip rip database
# show arp

* Delete RIP settings. *
(config)# no router rip
(config)# exit
# show ip rip database

* Routing through OSPF. *
(config)# router ospf 1
(config-router)# network 192.168.2.0 0.0.0.255 area 0
(config-router)# exit
(config)# exit
# show ip ospf
# show run

# show flash:
# sh flash:
# show run
# show running-config

* Backup running-config throwgh tftp. *
(en)# copy run tftp

* Initialize VLAN settings. *
> show vlan-switch
> enable
# show flash:
# delete flash:vlan.dat
# reload

* Create VLAN. *
* Attention!: At Cisco 1800 seriese and 800 seriese, [vlan database] erase all VLAN database. *
# vlan database
(vlan)# no vlan 4
(vlan)# vlan 5
(vlan)# exit
# configure terminal
(config)# interface fastEthernet 2
(config-if)# switchport access vlan 5
(config-if)# exit
(config)# interface fastEthernet 3
(config-if)# switchport mode trunk
(config-if)# exit
(config)# exit
# show vlan-switch

vim:set et sw=2 sts=2 ff=unix tw=0: